Re: No sound in 2.1.10

Fritz Ganter (ganter@rebekka.tu-graz.ac.at)
Sat, 23 Nov 1996 16:18:05 +0100 (MET)

On Sat, 16 Nov 1996, Fritz Ganter wrote:

> Hello Sir, hello list!
>
> I have here 2.1.10 on an alpha. Sound with Soundblaster 16 is compiled as
> module. When I do a insmod sound.o I get following output:
>
> root@jassi misc]# /sbin/insmod sound.o
> sound.o: In function Set_mixer_levels':
> sound_switch.c(.text+0x27dc): undefined reference to __copy_user'
> sound_switch.c(.text+0x27e0): undefined reference to __copy_user'
> sound_switch.c(.text+0x281c): undefined reference to __copy_user'
> sound_switch.c(.text+0x2820): undefined reference to __copy_user'
> sound.o: In function Get_mixer_levels':
> sound_switch.c(.text+0x28cc): undefined reference to __copy_user'
> sound.o(.text+0x28d0):sound_switch.c: more undefined references to
> __copy_user' follow
> /usr/tmp/sound314: No such file or directory
>
> 2.0.25 works fine.

ok., the same with 2.1.13. Compiling directly into the kernel works, but
in xquake the sound comes always about 1 second too late.

Hier is my /dev/sndstat:
Sound Driver:3.5.4-960630 (Tue Nov 12 17:13:33 MET 1996 root,
Linux jassi.tu-graz.ac.at 2.0.24 #21 Mon Nov 11 12:44:14 MET 1996 alpha)
Kernel: Linux jassi.tu-graz.ac.at 2.0.25 #26 Fri Nov 15 11:36:27 MET 1996 alpha
Config options: 0

Installed drivers:
Type 1: OPL-2/OPL-3 FM
Type 2: Sound Blaster
Type 7: SB MPU-401

Card config:
Sound Blaster at 0x220 irq 5 drq 1,6
SB MPU-401 at 0x330 irq 5 drq 0
OPL-2/OPL-3 FM at 0x388 drq 0

Audio devices:
0: Sound Blaster 16 (4.12)

Synth devices:
0: Yamaha OPL-3

Midi devices:
0: Sound Blaster 16

Timers:
0: System clock

Mixers:
0: Sound Blaster

Machine is an alpha cabriolet.

Fritz "who dances with the Linux" Ganter. ganter@fvkma.tu-graz.ac.at
WWW: http://fvkma.tu-graz.ac.at/ganter ganter@quant-x.com
EDV-Consulting F.Ganter Grazerstr. 26a,A-8045 Graz support@quant-x.com
Member of the Quant-X Group: Alpha based Systems running Linux

--
To unsubscribe: send e-mail to axp-list-request@redhat.com with
'unsubscribe' as the subject.  Do not send it to axp-list@redhat.com



Feedback | Store | News | Support | Product Errata | About Us | Linux Info | Search | JumpWords
No Frames | Show Frames

Copyright © 1995-1997 Red Hat Software. Legal notices